j2eefast vulnerabilities
Recent CVEs affecting j2eefast products. 18 tracked.
j2eefast has 18 tracked vulnerabilities, 8 critical. A fixed release or vendor patch exists for 1. Most recent: 2024-10-18. Highest priority: CVE-2024-45944 (score 59/100).
- CVE-2024-45944 CRITICAL 9.8 UPGRADE In J2eeFAST <=2.7, the backend function has unsafe filtering, which allows an attacker to trigger certain sens
- CVE-2024-35091 CRITICAL 9.8 DOWNGRADE J2EEFAST v2.7.0 was discovered to contain a SQL injection vulnerability via the findPage function in SysTenant
- CVE-2024-35090 HIGH 8.2 DOWNGRADE J2EEFAST v2.7.0 was discovered to contain a SQL injection vulnerability via the findPage function in SysUrepor
- CVE-2024-35086 CRITICAL 9.8 DOWNGRADE J2EEFAST v2.7.0 was discovered to contain a SQL injection vulnerability via the findPage function in BpmTaskFr
- CVE-2024-35085 MEDIUM 5.4 DOWNGRADE J2EEFAST v2.7.0 was discovered to contain a SQL injection vulnerability via the findPage function in ProcessDe
- CVE-2024-35084 CRITICAL 9.8 DOWNGRADE J2EEFAST v2.7.0 was discovered to contain a SQL injection vulnerability via the findPage function in SysMsgPus
- CVE-2024-35083 HIGH 8.8 DOWNGRADE J2EEFAST v2.7.0 was discovered to contain a SQL injection vulnerability via the findPage function in SysLoginI
- CVE-2024-35082 MEDIUM 6.3 DOWNGRADE J2EEFAST v2.7.0 was discovered to contain a SQL injection vulnerability via the findPage function in SysOperLo
- CVE-2024-33164 CRITICAL 9.8 DOWNGRADE J2EEFAST v2.7.0 was discovered to contain a SQL injection vulnerability via the sql_filter parameter in the au
- CVE-2024-33161 MEDIUM 5.3 DOWNGRADE J2EEFAST v2.7.0 was discovered to contain a SQL injection vulnerability via the sql_filter parameter in the un
- CVE-2024-33155 CRITICAL 9.8 DOWNGRADE J2EEFAST v2.7.0 was discovered to contain a SQL injection vulnerability via the sql_filter parameter in the ge
- CVE-2024-33153 CRITICAL 9.8 DOWNGRADE J2EEFAST v2.7.0 was discovered to contain a SQL injection vulnerability via the sql_filter parameter in the co
- CVE-2024-33149 HIGH 8.1 DOWNGRADE J2EEFAST v2.7.0 was discovered to contain a SQL injection vulnerability via the sql_filter parameter in the my
- CVE-2024-33148 HIGH 7.3 DOWNGRADE J2EEFAST v2.7.0 was discovered to contain a SQL injection vulnerability via the sql_filter parameter in the li
- CVE-2024-33147 HIGH 8.8 DOWNGRADE J2EEFAST v2.7.0 was discovered to contain a SQL injection vulnerability via the sql_filter parameter in the au
- CVE-2024-33146 CRITICAL 9.1 DOWNGRADE J2EEFAST v2.7.0 was discovered to contain a SQL injection vulnerability via the sql_filter parameter in the ex
- CVE-2024-33144 HIGH 8.8 DOWNGRADE J2EEFAST v2.7.0 was discovered to contain a SQL injection vulnerability via the sql_filter parameter in the fi
- CVE-2024-33139 HIGH 7.5 DOWNGRADE J2EEFAST v2.7.0 was discovered to contain a SQL injection vulnerability via the sql_filter parameter in the fi
FAQ
How do I fix j2eefast vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is j2eefast being exploited right now?
None of the tracked j2eefast CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which j2eefast CVE should I patch first?
CVE-2024-45944 currently ranks highest (59/100): In J2eeFAST <=2.7, the backend function has unsafe filtering, which allows an attacker to trigger certain sens.