libsixel vulnerabilities
Recent CVEs affecting libsixel products. 4 tracked.
libsixel has 4 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 3. Most recent: 2022-04-08. Highest priority: CVE-2021-41715 (score 52/100).
- CVE-2022-27938 MEDIUM 5.5 UPGRADE UPGRADE stb_image.h (aka the stb image loader) 2.19, as used in libsixel and other products, has a reachable assertion
- CVE-2021-45340 MEDIUM 6.5 UPGRADE In Libsixel prior to and including v1.10.3, a NULL pointer dereference in the stb_image.h component of libsixe
- CVE-2021-41715 HIGH 8.8 DOWNGRADE libsixel 1.10.0 is vulnerable to Use after free in libsixel/src/dither.c:379.
- CVE-2021-40656 HIGH 8.8 UPGRADE libsixel before 1.10 is vulnerable to Buffer Overflow in libsixel/src/quant.c:867.
FAQ
How do I fix libsixel vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is libsixel being exploited right now?
None of the tracked libsixel CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which libsixel CVE should I patch first?
CVE-2021-41715 currently ranks highest (52/100): libsixel 1.10.0 is vulnerable to Use after free in libsixel/src/dither.c:379..