llamaindex vulnerabilities
Recent CVEs affecting llamaindex products. 21 tracked.
llamaindex has 21 tracked vulnerabilities, 4 critical. A fixed release or vendor patch exists for 19. Most recent: 2026-01-12. Highest priority: CVE-2024-12909 (score 63/100).
- CVE-2025-6210 MEDIUM 6.2 UPGRADE A vulnerability in the ObsidianReader class of the run-llama/llama_index repository, specifically in version 0
- CVE-2025-7707 HIGH 7.8 UPGRADE The llama_index library version 0.12.33 sets the NLTK data directory to a subdirectory of the codebase by defa
- CVE-2024-58339 HIGH 7.5 UPGRADE LlamaIndex (run-llama/llama_index) versions up to and including 0.12.2 contain an uncontrolled resource consum
- CVE-2024-14021 HIGH 7.8 UPGRADE LlamaIndex (run-llama/llama_index) versions up to and including 0.11.6 contain an unsafe deserialization vulne
- CVE-2025-6211 MEDIUM 6.5 UPGRADE A vulnerability in the DocugamiReader class of the run-llama/llama_index repository, up to version 0.12.28, in
- CVE-2025-6209 HIGH 7.5 UPGRADE A path traversal vulnerability exists in run-llama/llama_index versions 0.12.27 through 0.12.40, specifically
- CVE-2025-5472 MEDIUM 6.5 UPGRADE The JSONReader in run-llama/llama_index versions 0.12.28 is vulnerable to a stack overflow due to uncontrolled
- CVE-2025-3225 HIGH 7.5 UPGRADE An XML Entity Expansion vulnerability, also known as a 'billion laughs' attack, exists in the sitemap parser o
- CVE-2025-3108 HIGH 7.5 UPGRADE A critical deserialization vulnerability exists in the run-llama/llama_index library's JsonPickleSerializer co
- CVE-2025-3046 HIGH 7.5 UPGRADE A vulnerability in the `ObsidianReader` class of the run-llama/llama_index repository, versions 0.12.23 to 0.1
- CVE-2025-3044 MEDIUM 5.3 UPGRADE A vulnerability in the ArxivReader class of the run-llama/llama_index repository, versions up to v0.12.22.post
- CVE-2025-1793 CRITICAL 9.8 UPGRADE Multiple vector store integrations in run-llama/llama_index version v0.12.21 have SQL injection vulnerabilitie
- CVE-2025-1753 HIGH 7.8 DOWNGRADE LLama-Index CLI version v0.12.20 contains an OS command injection vulnerability
- CVE-2025-1752 HIGH 7.5 UPGRADE A Denial of Service (DoS) vulnerability has been identified in the KnowledgeBaseWebReader class of the run-lla
- CVE-2025-1750 CRITICAL 9.8 UPGRADE An SQL injection vulnerability exists in the delete function of DuckDBVectorStore in run-llama/llama_index ver
- CVE-2024-45201 HIGH 8.8 UPGRADE An issue was discovered in llama_index before 0.10.38
- CVE-2024-12911 HIGH 7.1 UPGRADE A vulnerability in the `default_jsonalyzer` function of the `JSONalyzeQueryEngine` in the run-llama/llama_inde
- CVE-2024-12910 MEDIUM 5.9 UPGRADE A vulnerability in the `KnowledgeBaseWebReader` class of the run-llama/llama_index repository, version latest,
- CVE-2024-12909 CRITICAL 9.8 UPGRADE A vulnerability in the FinanceChatLlamaPack of the run-llama/llama_index repository, versions up to v0.12.3, a
- CVE-2024-12704 HIGH 7.5 DOWNGRADE A vulnerability in the LangChainLLM class of the run-llama/llama_index repository, version v0.12.5, allows for
- CVE-2024-11958 CRITICAL 9.8 UPGRADE A SQL injection vulnerability exists in the `duckdb_retriever` component of the run-llama/llama_index reposito
FAQ
How do I fix llamaindex vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is llamaindex being exploited right now?
None of the tracked llamaindex CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which llamaindex CVE should I patch first?
CVE-2024-12909 currently ranks highest (63/100): A vulnerability in the FinanceChatLlamaPack of the run-llama/llama_index repository, versions up to v0.12.3, a.