mailvelope vulnerabilities
Recent CVEs affecting mailvelope products. 4 tracked.
mailvelope has 4 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 4. Most recent: 2019-07-09. Highest priority: CVE-2019-9149 (score 48/100).
- CVE-2019-9150 MEDIUM 5.3 UPGRADE Mailvelope prior to 3.3.0 does not require user interaction to import public keys shown on web page
- CVE-2019-9149 MEDIUM 6.5 UPGRADE Mailvelope prior to 3.3.0 allows private key operations without user interaction via its client-API
- CVE-2019-9148 MEDIUM 4.3 UPGRADE Mailvelope prior to 3.3.0 accepts or operates with invalid PGP public keys: Mailvelope allows importing keys t
- CVE-2019-9147 MEDIUM 4.3 UPGRADE Mailvelope prior to 3.1.0 is vulnerable to a clickjacking attack against the settings page
FAQ
How do I fix mailvelope vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is mailvelope being exploited right now?
None of the tracked mailvelope CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which mailvelope CVE should I patch first?
CVE-2019-9149 currently ranks highest (48/100): Mailvelope prior to 3.3.0 allows private key operations without user interaction via its client-API.