oceanwp vulnerabilities
Recent CVEs affecting oceanwp products. 8 tracked.
oceanwp has 8 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 8. Most recent: 2025-09-05. Highest priority: CVE-2025-3472 (score 48/100).
- CVE-2023-0749 MEDIUM 6.5 UPGRADE The Ocean Extra WordPress plugin before 2.1.3 does not ensure that the template to be loaded via a shortcode i
- CVE-2025-8944 MEDIUM 4.3 UPGRADE The OceanWP WordPress theme before 4.1.2 is vulnerable to an option update due to a missing capability check o
- CVE-2025-8891 MEDIUM 4.3 UPGRADE The OceanWP theme for WordPress is vulnerable to Cross-Site Request Forgery in versions 4.0.9 to 4.1.1
- CVE-2025-3472 MEDIUM 6.5 UPGRADE The Ocean Extra plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and
- CVE-2025-3458 MEDIUM 6.4 UPGRADE The Ocean Extra plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'ocean_gallery_id’ p
- CVE-2025-3457 MEDIUM 6.4 UPGRADE The Ocean Extra plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'oceanwp_ic
- CVE-2024-3167 MEDIUM 6.4 UPGRADE The Ocean Extra plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘twitter_username’ p
- CVE-2024-37489 MEDIUM 6.5 UPGRADE Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in O
FAQ
How do I fix oceanwp vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is oceanwp being exploited right now?
None of the tracked oceanwp CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which oceanwp CVE should I patch first?
CVE-2025-3472 currently ranks highest (48/100): The Ocean Extra plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and.