openharmony vulnerabilities
Recent CVEs affecting openharmony products. 18 tracked.
openharmony has 18 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 17. Most recent: 2023-01-09. Highest priority: CVE-2022-38700 (score 39/100).
- CVE-2022-45877 HIGH 8.3 UPGRADE OpenHarmony-v3.1.4 and prior versions had an vulnerability
- CVE-2022-45126 MEDIUM 4.0 UPGRADE UPGRADE Kernel subsystem within OpenHarmony-v3.1.4 and prior versions in kernel_liteos_a has a kernel stack overflow v
- CVE-2022-45118 MEDIUM 6.2 UPGRADE OpenHarmony-v3.1.2 and prior versions had a vulnerability that telephony in communication subsystem sends publ
- CVE-2022-44455 MEDIUM 6.8 UPGRADE UPGRADE The appspawn and nwebspawn services within OpenHarmony-v3.1.2 and prior versions were found to be vulnerable t
- CVE-2022-43662 MEDIUM 4.0 UPGRADE UPGRADE Kernel subsystem within OpenHarmony-v3.1.4 and prior versions in kernel_liteos_a has a kernel stack overflow v
- CVE-2022-43495 MEDIUM 6.5 UPGRADE OpenHarmony-v3.1.2 and prior versions had a DOS vulnerability in distributedhardware_device_manager when joini
- CVE-2022-43451 HIGH 8.4 UPGRADE OpenHarmony-v3.1.2 and prior versions had an Multiple path traversal vulnerability in appspawn and nwebspawn s
- CVE-2022-43449 MEDIUM 6.2 UPGRADE OpenHarmony-v3.1.2 and prior versions had an Arbitrary file read vulnerability via download_server
- CVE-2022-42488 HIGH 8.4 UPGRADE OpenHarmony-v3.1.2 and prior versions have a Missing permission validation vulnerability in param service of s
- CVE-2022-42464 MEDIUM 6.7 UPGRADE OpenHarmony-v3.1.2 and prior versions, 3.0.6 and prior versions have a Kernel memory pool override vulnerabili
- CVE-2022-42463 HIGH 8.3 UPGRADE OpenHarmony-v3.1.2 and prior versions have an authenication bypass vulnerability in a callback handler functio
- CVE-2022-41802 MEDIUM 4.0 UPGRADE UPGRADE Kernel subsystem within OpenHarmony-v3.1.4 and prior versions in kernel_liteos_a has a kernel stack overflow v
- CVE-2022-41686 MEDIUM 5.1 UPGRADE UPGRADE OpenHarmony-v3.1.2 and prior versions, 3.0.6 and prior versions have an Out-of-bound memory read and write vul
- CVE-2022-38701 MEDIUM 6.2 UPGRADE UPGRADE OpenHarmony-v3.1.2 and prior versions have a heap overflow vulnerability
- CVE-2022-38700 HIGH 8.8 DOWNGRADE OpenHarmony-v3.1.1 and prior versions have a permission bypass vulnerability
- CVE-2022-38081 MEDIUM 6.2 UPGRADE OpenHarmony-v3.1.2 and prior versions have a permission bypass vulnerability
- CVE-2022-38064 MEDIUM 6.2 UPGRADE OpenHarmony-v3.1.2 and prior versions have a permission bypass vulnerability
- CVE-2022-36423 HIGH 7.4 UPGRADE UPGRADE OpenHarmony-v3.1.2 and prior versions have an incorrect configuration of the cJSON library, which leads a Stac
FAQ
How do I fix openharmony vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is openharmony being exploited right now?
None of the tracked openharmony CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which openharmony CVE should I patch first?
CVE-2022-38700 currently ranks highest (39/100): OpenHarmony-v3.1.1 and prior versions have a permission bypass vulnerability.