<?xml version="1.0" encoding="UTF-8"?><?xml-stylesheet type="text/xsl" href="../assets/feed.xsl"?><rss version="2.0"><channel><title>PatchTheCVE: osrg</title><link>https://patchthecve.com/</link><description>CVEs with upgrade or downgrade fix steps</description><item><title>CVE-2026-42285: GoBGP is an open source Border Gateway Protocol (BGP) implementation in the Go Programming Language</title><link>https://patchthecve.com/cve/CVE-2026-42285.html</link><guid>https://patchthecve.com/cve/CVE-2026-42285.html</guid><pubDate>Mon, 26 Oct 2026 22:10:00 +0000</pubDate><description>HIGH 7.5: GoBGP is an open source Border Gateway Protocol (BGP) implementation in the Go Programming Language. In version 4.4.0, an unauthenticated remote BGP peer can trigger a fatal panic in GoBGP by sending a specially crafted BGP UPDATE message. When the server receives a message with inconsistent attribu</description></item><item><title>CVE-2026-41643: GoBGP is an open source Border Gateway Protocol (BGP) implementation in the Go Programming Language</title><link>https://patchthecve.com/cve/CVE-2026-41643.html</link><guid>https://patchthecve.com/cve/CVE-2026-41643.html</guid><pubDate>Mon, 26 Oct 2026 21:10:00 +0000</pubDate><description>HIGH 7.5: GoBGP is an open source Border Gateway Protocol (BGP) implementation in the Go Programming Language. Prior to version 4.3.0, a remote Denial of Service (DoS) vulnerability exists in GoBGP where a malformed BGP UPDATE message can trigger a runtime error: index out of range panic. This occurs during t</description></item><item><title>CVE-2026-41642: GoBGP is an open source Border Gateway Protocol (BGP) implementation in the Go Programming Language</title><link>https://patchthecve.com/cve/CVE-2026-41642.html</link><guid>https://patchthecve.com/cve/CVE-2026-41642.html</guid><pubDate>Mon, 26 Oct 2026 22:10:00 +0000</pubDate><description>HIGH 7.5: GoBGP is an open source Border Gateway Protocol (BGP) implementation in the Go Programming Language. In version 4.3.0, a remote Denial of Service (DoS) vulnerability exists in GoBGP due to a nil pointer dereference. When a malformed BGP UPDATE message contains an unrecognized Path Attribute marked a</description></item><item><title>CVE-2026-7737: A vulnerability was identified in osrg GoBGP up to 4.3.0</title><link>https://patchthecve.com/cve/CVE-2026-7737.html</link><guid>https://patchthecve.com/cve/CVE-2026-7737.html</guid><pubDate>Mon, 26 Oct 2026 19:10:00 +0000</pubDate><description>MEDIUM 5.3: A vulnerability was identified in osrg GoBGP up to 4.3.0. Affected by this issue is the function BMPPeerUpNotification.ParseBody/BMPStatisticsReport.ParseBody of the file pkg/packet/bmp/bmp.go of the component BMP Parser. The manipulation leads to out-of-bounds read. The attack can be initiated remo</description></item><item><title>CVE-2026-7736: A vulnerability was determined in osrg GoBGP up to 4.3.0</title><link>https://patchthecve.com/cve/CVE-2026-7736.html</link><guid>https://patchthecve.com/cve/CVE-2026-7736.html</guid><pubDate>Mon, 26 Oct 2026 19:10:00 +0000</pubDate><description>HIGH 7.3: A vulnerability was determined in osrg GoBGP up to 4.3.0. Affected by this vulnerability is the function parseRibEntry of the file pkg/packet/mrt/mrt.go. Executing a manipulation can lead to integer underflow. It is possible to launch the attack remotely. Upgrading to version 4.4.0 addresses this is</description></item><item><title>CVE-2026-7735: A vulnerability was found in osrg GoBGP up to 4.3.0</title><link>https://patchthecve.com/cve/CVE-2026-7735.html</link><guid>https://patchthecve.com/cve/CVE-2026-7735.html</guid><pubDate>Mon, 26 Oct 2026 19:10:00 +0000</pubDate><description>HIGH 7.3: A vulnerability was found in osrg GoBGP up to 4.3.0. Affected is the function PathAttributeAigp.DecodeFromBytes of the file pkg/packet/bgp/bgp.go of the component AIGP Attribute Parser. Performing a manipulation results in buffer overflow. It is possible to initiate the attack remotely. Upgrading to</description></item><item><title>CVE-2026-7734: A vulnerability has been found in osrg GoBGP up to 4.3.0</title><link>https://patchthecve.com/cve/CVE-2026-7734.html</link><guid>https://patchthecve.com/cve/CVE-2026-7734.html</guid><pubDate>Mon, 26 Oct 2026 19:10:00 +0000</pubDate><description>MEDIUM 5.3: A vulnerability has been found in osrg GoBGP up to 4.3.0. This impacts the function SRv6L3ServiceAttribute.DecodeFromBytes of the file pkg/packet/bgp/prefix_sid.go of the component SRv6 L3 Service. Such manipulation of the argument data leads to denial of service. The attack may be performed from re</description></item></channel></rss>