snort vulnerabilities
Recent CVEs affecting snort products. 18 tracked.
snort has 18 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 11. Most recent: 2023-11-01. Highest priority: CVE-2006-5276 (score 65/100).
- CVE-2000-1226 MEDIUM 5.0 DOWNGRADE Snort 1.6, when running in straight ASCII packet logging mode or IDS mode with straight decoded ASCII packet l
- CVE-2021-1223 HIGH 7.5 DOWNGRADE UPGRADE Multiple Cisco products are affected by a vulnerability in the Snort detection engine that could allow an unau
- CVE-2021-40114 MEDIUM 6.8 DOWNGRADE UPGRADE Multiple Cisco products are affected by a vulnerability in the way the Snort detection engine processes ICMP t
- CVE-2021-1224 MEDIUM 5.8 DOWNGRADE UPGRADE Multiple Cisco products are affected by a vulnerability with TCP Fast Open (TFO) when used in conjunction with
- CVE-2021-1495 MEDIUM 5.8 UPGRADE UPGRADE Multiple Cisco products are affected by a vulnerability in the Snort detection engine that could allow an unau
- CVE-2021-1236 MEDIUM 5.3 UPGRADE DOWNGRADE Multiple Cisco products are affected by a vulnerability in the Snort application detection engine that could a
- CVE-2020-3299 MEDIUM 5.8 UPGRADE UPGRADE Multiple Cisco products are affected by a vulnerability in the Snort detection engine that could allow an unau
- CVE-2023-20246 MEDIUM 5.8 UPGRADE UPGRADE Multiple Cisco products are affected by a vulnerability in Snort access control policies that could allow an u
- CVE-2016-1417 HIGH 8.8 DOWNGRADE Untrusted search path vulnerability in Snort 2.9.7.0-WIN32 allows remote attackers to execute arbitrary code a
- CVE-2009-3641 MEDIUM 4.3 UPGRADE Snort before 2.8.5.1, when the -v option is enabled, allows remote attackers to cause a denial of service (app
- CVE-2008-1804 MEDIUM 6.8 UPGRADE preprocessors/spp_frag3.c in Sourcefire Snort before 2.8.1 does not properly identify packet fragments that ha
- CVE-2007-1398 HIGH 7.1 DOWNGRADE The frag3 preprocessor in Snort 2.6.1.1, 2.6.1.2, and 2.7.0 beta, when configured for inline use on Linux with
- CVE-2007-0251 HIGH 7.8 DOWNGRADE Integer underflow in the DecodeGRE function in src/decode.c in Snort 2.6.1.2 allows remote attackers to trigge
- CVE-2006-6931 MEDIUM 5.0 UPGRADE Algorithmic complexity vulnerability in Snort before 2.6.1, during predicate evaluation in rule matching for c
- CVE-2006-5276 HIGH 10.0 UPGRADE DOWNGRADE Stack-based buffer overflow in the DCE/RPC preprocessor in Snort before 2.6.1.3, and 2.7 before beta 2; and So
- CVE-2003-0033 HIGH 10.0 DOWNGRADE Buffer overflow in the RPC preprocessor for Snort 1.8 and 1.9.x before 1.9.1 allows remote attackers to execut
- CVE-2001-1558 MEDIUM 5.0 DOWNGRADE Unknown vulnerability in IP defragmenter (frag2) in Snort before 1.8.3 allows attackers to cause a denial of s
- CVE-2001-0669 HIGH 7.5 MITIGATE MITIGATE Various Intrusion Detection Systems (IDS) including (1) Cisco Secure Intrusion Detection System, (2) Cisco Cat
FAQ
How do I fix snort vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is snort being exploited right now?
None of the tracked snort CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which snort CVE should I patch first?
CVE-2006-5276 currently ranks highest (65/100): Stack-based buffer overflow in the DCE/RPC preprocessor in Snort before 2.6.1.3, and 2.7 before beta 2; and So.