snyk vulnerabilities
Recent CVEs affecting snyk products. 3 tracked.
snyk has 3 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 3. Most recent: 2025-06-26. Highest priority: CVE-2024-48964 (score 36/100).
- CVE-2025-6624 HIGH 7.2 UPGRADE Versions of the package snyk before 1.1297.3 are vulnerable to Insertion of Sensitive Information into Log Fil
- CVE-2024-48964 HIGH 7.5 UPGRADE The package Snyk CLI before 1.1294.0 is vulnerable to Code Injection when scanning an untrusted Gradle project
- CVE-2024-48963 HIGH 7.5 UPGRADE The package Snyk CLI before 1.1294.0 is vulnerable to Code Injection when scanning an untrusted PHP project
FAQ
How do I fix snyk vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is snyk being exploited right now?
None of the tracked snyk CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which snyk CVE should I patch first?
CVE-2024-48964 currently ranks highest (36/100): The package Snyk CLI before 1.1294.0 is vulnerable to Code Injection when scanning an untrusted Gradle project.