<?xml version="1.0" encoding="UTF-8"?><?xml-stylesheet type="text/xsl" href="../assets/feed.xsl"?><rss version="2.0"><channel><title>PatchTheCVE: spice project</title><link>https://patchthecve.com/</link><description>CVEs with upgrade or downgrade fix steps</description><item><title>CVE-2021-20201: A flaw was found in spice in versions before 0.14.92</title><link>https://patchthecve.com/cve/CVE-2021-20201.html</link><guid>https://patchthecve.com/cve/CVE-2021-20201.html</guid><pubDate>Wed, 17 Jun 2026 03:33:27 +0000</pubDate><description>MEDIUM 5.3: A flaw was found in spice in versions before 0.14.92. A DoS tool might make it easier for remote attackers to cause a denial of service (CPU consumption) by performing many renegotiations within a single connection.</description></item><item><title>CVE-2020-14355: Multiple buffer overflow vulnerabilities were found in the QUIC image decoding process of the SPICE remote dis</title><link>https://patchthecve.com/cve/CVE-2020-14355.html</link><guid>https://patchthecve.com/cve/CVE-2020-14355.html</guid><pubDate>Wed, 17 Jun 2026 02:54:36 +0000</pubDate><description>MEDIUM 6.6: Multiple buffer overflow vulnerabilities were found in the QUIC image decoding process of the SPICE remote display system, before spice-0.14.2-1. Both the SPICE client (spice-gtk) and server are affected by these flaws. These flaws allow a malicious client or server to send specially crafted message</description></item><item><title>CVE-2019-3813: Spice, versions 0.5.2 through 0.14.1, are vulnerable to an out-of-bounds read due to an off-by-one error in me</title><link>https://patchthecve.com/cve/CVE-2019-3813.html</link><guid>https://patchthecve.com/cve/CVE-2019-3813.html</guid><pubDate>Wed, 17 Jun 2026 02:35:38 +0000</pubDate><description>HIGH 7.5: Spice, versions 0.5.2 through 0.14.1, are vulnerable to an out-of-bounds read due to an off-by-one error in memslot_get_virt. This may lead to a denial of service, or, in the worst case, code-execution by unauthenticated attackers.</description></item><item><title>CVE-2018-10893: Multiple integer overflow and buffer overflow issues were discovered in spice-client&#x27;s handling of LZ compress</title><link>https://patchthecve.com/cve/CVE-2018-10893.html</link><guid>https://patchthecve.com/cve/CVE-2018-10893.html</guid><pubDate>Wed, 17 Jun 2026 01:34:51 +0000</pubDate><description>HIGH 7.6: Multiple integer overflow and buffer overflow issues were discovered in spice-client&#x27;s handling of LZ compressed frames. A malicious server could cause the client to crash or, potentially, execute arbitrary code.</description></item><item><title>CVE-2018-10873: A vulnerability was discovered in SPICE before version 0.14.1 where the generated code used for demarshalling </title><link>https://patchthecve.com/cve/CVE-2018-10873.html</link><guid>https://patchthecve.com/cve/CVE-2018-10873.html</guid><pubDate>Wed, 17 Jun 2026 01:34:48 +0000</pubDate><description>HIGH 8.3: A vulnerability was discovered in SPICE before version 0.14.1 where the generated code used for demarshalling messages lacked sufficient bounds checks. A malicious client or server, after authentication, could send specially crafted messages to its peer which would result in a crash or, potentially,</description></item><item><title>CVE-2016-9578: A vulnerability was discovered in SPICE before 0.13.90 in the server&#x27;s protocol handling</title><link>https://patchthecve.com/cve/CVE-2016-9578.html</link><guid>https://patchthecve.com/cve/CVE-2016-9578.html</guid><pubDate>Wed, 17 Jun 2026 00:56:16 +0000</pubDate><description>HIGH 7.5: A vulnerability was discovered in SPICE before 0.13.90 in the server&#x27;s protocol handling. An attacker able to connect to the SPICE server could send crafted messages which would cause the process to crash.</description></item><item><title>CVE-2016-9577: A vulnerability was discovered in SPICE before 0.13.90 in the server&#x27;s protocol handling</title><link>https://patchthecve.com/cve/CVE-2016-9577.html</link><guid>https://patchthecve.com/cve/CVE-2016-9577.html</guid><pubDate>Wed, 17 Jun 2026 00:56:16 +0000</pubDate><description>HIGH 7.5: A vulnerability was discovered in SPICE before 0.13.90 in the server&#x27;s protocol handling. An authenticated attacker could send crafted messages to the SPICE server causing a heap overflow leading to a crash or possible code execution.</description></item><item><title>CVE-2017-7506: spice versions though 0.13 are vulnerable to out-of-bounds memory access when processing specially crafted mes</title><link>https://patchthecve.com/cve/CVE-2017-7506.html</link><guid>https://patchthecve.com/cve/CVE-2017-7506.html</guid><pubDate>Wed, 17 Jun 2026 01:24:29 +0000</pubDate><description>HIGH 8.8: spice versions though 0.13 are vulnerable to out-of-bounds memory access when processing specially crafted messages from authenticated attacker to the spice server resulting into crash and/or server memory leak.</description></item><item><title>CVE-2015-3247: Race condition in the worker_update_monitors_config function in SPICE 0.12.4 allows a remote authenticated gue</title><link>https://patchthecve.com/cve/CVE-2015-3247.html</link><guid>https://patchthecve.com/cve/CVE-2015-3247.html</guid><pubDate>Wed, 17 Jun 2026 00:25:36 +0000</pubDate><description>MEDIUM 6.9: Race condition in the worker_update_monitors_config function in SPICE 0.12.4 allows a remote authenticated guest user to cause a denial of service (heap-based memory corruption and QEMU-KVM crash) or possibly execute arbitrary code on the host via unspecified vectors.</description></item><item><title>CVE-2013-4282: Stack-based buffer overflow in the reds_handle_ticket function in server/reds.c in SPICE 0.12.0 allows remote </title><link>https://patchthecve.com/cve/CVE-2013-4282.html</link><guid>https://patchthecve.com/cve/CVE-2013-4282.html</guid><pubDate>Tue, 16 Jun 2026 23:56:56 +0000</pubDate><description>MEDIUM 5.0: Stack-based buffer overflow in the reds_handle_ticket function in server/reds.c in SPICE 0.12.0 allows remote attackers to cause a denial of service (crash) via a long password in a SPICE ticket.</description></item><item><title>CVE-2013-4130: The (1) red_channel_pipes_add_type and (2) red_channel_pipes_add_empty_msg functions in server/red_channel.c i</title><link>https://patchthecve.com/cve/CVE-2013-4130.html</link><guid>https://patchthecve.com/cve/CVE-2013-4130.html</guid><pubDate>Tue, 16 Jun 2026 23:56:40 +0000</pubDate><description>MEDIUM 5.0: The (1) red_channel_pipes_add_type and (2) red_channel_pipes_add_empty_msg functions in server/red_channel.c in SPICE before 0.12.4 do not properly perform ring loops, which might allow remote attackers to cause a denial of service (reachable assertion and server exit) by triggering a network error.</description></item></channel></rss>