starwindsoftware vulnerabilities
Recent CVEs affecting starwindsoftware products. 19 tracked.
starwindsoftware has 19 tracked vulnerabilities, 2 critical. A fixed release or vendor patch exists for 16. Most recent: 2022-06-03. Highest priority: CVE-2021-42574 (score 58/100).
- CVE-2021-37750 MEDIUM 6.5 UPGRADE MITIGATE The Key Distribution Center (KDC) in MIT Kerberos 5 (aka krb5) before 1.18.5 and 1.19.x before 1.19.3 has a NU
- CVE-2022-32268 HIGH 8.8 DOWNGRADE StarWind SAN and NAS v0.2 build 1914 allow remote code execution
- CVE-2022-24552 CRITICAL 9.8 UPGRADE UPGRADE A flaw was found in the REST API in StarWind Stack
- CVE-2022-24551 HIGH 8.8 UPGRADE UPGRADE A flaw was found in StarWind Stack
- CVE-2022-23858 HIGH 8.8 DOWNGRADE A flaw was found in the REST API
- CVE-2021-42739 MEDIUM 6.7 UPGRADE MITIGATE The firewire subsystem in the Linux kernel through 5.14.13 has a buffer overflow related to drivers/media/fire
- CVE-2021-42574 HIGH 8.3 UPGRADE MITIGATE An issue was discovered in the Bidirectional Algorithm in the Unicode Specification through 14.0
- CVE-2021-20271 HIGH 7.0 UPGRADE MITIGATE A flaw was found in RPM's signature check functionality when reading a package file
- CVE-2020-36322 MEDIUM 5.5 UPGRADE MITIGATE An issue was discovered in the FUSE filesystem implementation in the Linux kernel before 5.10.6, aka CID-5d069
- CVE-2020-25704 MEDIUM 5.5 UPGRADE MITIGATE A flaw memory leak in the Linux kernel performance monitoring subsystem was found in the way if using PERF_EVE
- CVE-2020-25656 MEDIUM 4.1 UPGRADE MITIGATE A flaw was found in the Linux kernel
- CVE-2020-25643 HIGH 7.2 UPGRADE MITIGATE A flaw was found in the HDLC_PPP module of the Linux kernel in versions before 5.9-rc7
- CVE-2020-24394 HIGH 7.1 UPGRADE MITIGATE In the Linux kernel before 5.7.8, fs/nfsd/vfs.c (in the NFS server) can set incorrect permissions on new files
- CVE-2020-14409 HIGH 7.8 UPGRADE MITIGATE SDL (Simple DirectMedia Layer) through 2.0.12 has an Integer Overflow (and resultant SDL_memcpy heap corruptio
- CVE-2020-14314 MEDIUM 5.5 UPGRADE MITIGATE A memory out-of-bounds read flaw was found in the Linux kernel before 5.9-rc2 with the ext3/ext4 file system,
- CVE-2020-0427 MEDIUM 5.5 MITIGATE MITIGATE In create_pinctrl of core.c, there is a possible out of bounds read due to a use after free
- CVE-2019-20807 MEDIUM 5.3 UPGRADE MITIGATE In Vim before 8.1.0881, users can circumvent the rvim restricted mode and execute arbitrary OS commands via sc
- CVE-2013-20004 CRITICAL 9.8 UPGRADE A flaw was found in StarWind iSCSI target
- CVE-2007-20001 HIGH 7.5 UPGRADE A flaw was found in StarWind iSCSI target
FAQ
How do I fix starwindsoftware vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is starwindsoftware being exploited right now?
None of the tracked starwindsoftware CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which starwindsoftware CVE should I patch first?
CVE-2021-42574 currently ranks highest (58/100): An issue was discovered in the Bidirectional Algorithm in the Unicode Specification through 14.0.