talend vulnerabilities
Recent CVEs affecting talend products. 9 tracked.
talend has 9 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 8. Most recent: 2023-06-26. Highest priority: CVE-2023-36301 (score 46/100).
- CVE-2022-45589 HIGH 7.2 UPGRADE All versions before 8.0.1-R2022-10-RT and 7.3.1-R2022-09-RT of the Talend ESB Runtime are potentially vulnerab
- CVE-2022-45588 HIGH 7.8 UPGRADE All versions before R2022-09 of Talend's Remote Engine Gen 2 are potentially vulnerable to XML External Entity
- CVE-2023-36301 HIGH 7.5 UPGRADE Talend Data Catalog before 8.0-20230221 contain a directory traversal vulnerability in HeaderImageServlet.
- CVE-2023-33247 HIGH 7.5 UPGRADE Talend Data Catalog remote harvesting server before 8.0-20230413 contains a /upgrade endpoint that allows an u
- CVE-2023-31444 HIGH 7.5 UPGRADE In Talend Studio before 7.3.1-R2022-10 and 8.x before 8.0.1-R2022-09, microservices allow unauthenticated acce
- CVE-2023-26264 MEDIUM 5.5 UPGRADE All versions of Talend Data Catalog before 8.0-20220907 are potentially vulnerable to XML External Entity (XXE
- CVE-2023-26263 MEDIUM 5.5 UPGRADE All versions of Talend Data Catalog before 8.0-20230110 are potentially vulnerable to XML External Entity (XXE
- CVE-2022-30332 MEDIUM 5.3 DOWNGRADE In Talend Administration Center 7.3.1.20200219 before TAC-15950, the Forgot Password feature provides differen
- CVE-2021-4311 MEDIUM 5.5 UPGRADE A vulnerability classified as problematic was found in Talend Open Studio for MDM
FAQ
How do I fix talend vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is talend being exploited right now?
None of the tracked talend CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which talend CVE should I patch first?
CVE-2023-36301 currently ranks highest (46/100): Talend Data Catalog before 8.0-20230221 contain a directory traversal vulnerability in HeaderImageServlet..