thenewsletterplugin vulnerabilities
Recent CVEs affecting thenewsletterplugin products. 4 tracked.
thenewsletterplugin has 4 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 4. Most recent: 2025-06-09. Highest priority: CVE-2024-5317 (score 28/100).
- CVE-2025-3584 MEDIUM 4.8 UPGRADE The Newsletter WordPress plugin before 8.8.2 does not sanitise and escape some of its Subscription settings,
- CVE-2025-3582 MEDIUM 4.8 UPGRADE The Newsletter WordPress plugin before 8.85 does not sanitise and escape some of its Form settings, which cou
- CVE-2025-3581 MEDIUM 4.8 UPGRADE The Newsletter WordPress plugin before 8.8.5 does not validate and escape some of its Widget options before o
- CVE-2024-5317 MEDIUM 6.4 UPGRADE The Newsletter plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'np1' parameter in al
FAQ
How do I fix thenewsletterplugin vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is thenewsletterplugin being exploited right now?
None of the tracked thenewsletterplugin CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which thenewsletterplugin CVE should I patch first?
CVE-2024-5317 currently ranks highest (28/100): The Newsletter plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'np1' parameter in al.