thimpress vulnerabilities
Recent CVEs affecting thimpress products. 18 tracked.
thimpress has 18 tracked vulnerabilities, 1 critical. A fixed release or vendor patch exists for 18. Most recent: 2025-08-20. Highest priority: CVE-2025-28982 (score 48/100).
- CVE-2025-48267 HIGH 8.6 UPGRADE Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in ThimPress WP P
- CVE-2025-47664 MEDIUM 4.4 UPGRADE Server-Side Request Forgery (SSRF) vulnerability in ThimPress WP Pipes allows Server Side Request Forgery
- CVE-2025-28982 CRITICAL 9.3 UPGRADE Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in ThimPres
- CVE-2025-28979 HIGH 8.1 UPGRADE Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulner
- CVE-2025-28977 HIGH 7.1 UPGRADE Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ThimPres
- CVE-2024-9881 MEDIUM 4.8 UPGRADE The LearnPress WordPress plugin before 4.2.7.2 does not sanitise and escape some of its settings, which could
- CVE-2024-9609 MEDIUM 6.1 UPGRADE The LearnPress Export Import – WordPress extension for LearnPress plugin for WordPress is vulnerable to Reflec
- CVE-2024-7717 HIGH 8.8 UPGRADE The WP Events Manager plugin for WordPress is vulnerable to time-based SQL Injection via the ‘order’ parameter
- CVE-2024-51582 HIGH 7.5 UPGRADE Path Traversal: '.../...//' vulnerability in ThimPress WP Hotel Booking wp-hotel-booking allows PHP Local File
- CVE-2024-39641 MEDIUM 4.3 UPGRADE Cross-Site Request Forgery (CSRF) vulnerability in ThimPress LearnPress.This issue affects LearnPress: from n/
- CVE-2024-13599 MEDIUM 6.4 UPGRADE The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all
- CVE-2024-13447 MEDIUM 4.3 UPGRADE The WP Hotel Booking plugin for WordPress is vulnerable to unauthorized access of data due to a missing capabi
- CVE-2024-13128 MEDIUM 4.8 UPGRADE The LearnPress WordPress plugin before 4.2.7.5.1 does not sanitise and escape some of its settings, which cou
- CVE-2024-13127 MEDIUM 4.8 UPGRADE The LearnPress WordPress plugin before 4.2.7.5.1 does not sanitise and escape some of its settings, which cou
- CVE-2024-12370 MEDIUM 5.3 UPGRADE The WP Hotel Booking plugin for WordPress is vulnerable to unauthorized modification of data due to a missing
- CVE-2024-12283 MEDIUM 6.1 UPGRADE The WP Pipes plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘x1’ parameter in al
- CVE-2024-11868 MEDIUM 5.3 UPGRADE The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to Sensitive Information Exposure in
- CVE-2024-10010 MEDIUM 4.8 UPGRADE The LearnPress WordPress plugin before 4.2.7.2 does not sanitise and escape some of its settings, which could
FAQ
How do I fix thimpress vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is thimpress being exploited right now?
None of the tracked thimpress CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which thimpress CVE should I patch first?
CVE-2025-28982 currently ranks highest (48/100): Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in ThimPres.