untangle vulnerabilities
Recent CVEs affecting untangle products. 5 tracked.
untangle has 5 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 1. Most recent: 2020-11-12. Highest priority: CVE-2019-18647 (score 45/100).
- CVE-2020-17494 MEDIUM 5.3 UPGRADE Untangle Firewall NG before 16.0 uses MD5 for passwords.
- CVE-2019-18649 MEDIUM 4.8 DOWNGRADE When logged in as an admin user, the Title input field (under Reports) within Untangle NG firewall 14.2.0 is v
- CVE-2019-18648 MEDIUM 4.8 DOWNGRADE When logged in as an admin user, the Untangle NG firewall 14.2.0 is vulnerable to reflected XSS at multiple pl
- CVE-2019-18647 HIGH 7.2 DOWNGRADE The Untangle NG firewall 14.2.0 is vulnerable to an authenticated command injection when logged in as an admin
- CVE-2019-18646 HIGH 7.2 DOWNGRADE The Untangle NG firewall 14.2.0 is vulnerable to authenticated inline-query SQL injection within the timeDataD
FAQ
How do I fix untangle vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is untangle being exploited right now?
None of the tracked untangle CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which untangle CVE should I patch first?
CVE-2019-18647 currently ranks highest (45/100): The Untangle NG firewall 14.2.0 is vulnerable to an authenticated command injection when logged in as an admin.