vanillaforums vulnerabilities
Recent CVEs affecting vanillaforums products. 20 tracked.
vanillaforums has 20 tracked vulnerabilities, 2 critical. A fixed release or vendor patch exists for 17. Most recent: 2021-06-22. Highest priority: CVE-2018-18903 (score 67/100).
- CVE-2020-8825 MEDIUM 5.4 DOWNGRADE index.php?p=/dashboard/settings/branding in Vanilla 2.6.3 allows stored XSS.
- CVE-2019-9889 LOW 2.7 UPGRADE In Vanilla before 2.6.4, a flaw exists within the getSingleIndex function of the AddonManager class
- CVE-2019-8279 MEDIUM 5.4 UPGRADE Multiple stored XSS in Vanilla Forums before 2.5 allow remote attackers to inject arbitrary JavaScript code in
- CVE-2018-19499 HIGH 7.2 UPGRADE Vanilla before 2.5.5 and 2.6.x before 2.6.2 allows Remote Code Execution because authenticated administrators
- CVE-2018-18903 CRITICAL 9.8 UPGRADE Vanilla 2.6.x before 2.6.4 allows remote code execution.
- CVE-2018-17571 MEDIUM 6.1 UPGRADE Vanilla before 2.6.1 allows XSS via the email field of a profile.
- CVE-2018-16410 MEDIUM 6.5 DOWNGRADE Vanilla before 2.6.1 allows SQL injection via an invitationID array to /profile/deleteInvitation, related to a
- CVE-2018-15833 MEDIUM 4.3 UPGRADE In Vanilla before 2.6.1, the polling functionality allows Insecure Direct Object Reference (IDOR) via the Poll
- CVE-2017-1000432 HIGH 8.0 UPGRADE Vanilla Forums below 2.1.5 are affected by CSRF leading to Deleting topics and comments from forums Admin acce
- CVE-2016-10073 HIGH 7.5 UPGRADE The from method in library/core/class.email.php in Vanilla Forums before 2.3.1 allows remote attackers to spoo
- CVE-2014-9685 MEDIUM 4.3 UPGRADE DOWNGRADE Multiple cross-site scripting (XSS) vulnerabilities in Vanilla Forums before 2.0.18.13 and 2.1.x before 2.1.1
- CVE-2013-3528 HIGH 7.5 UPGRADE Unspecified vulnerability in the update check in Vanilla Forums before 2.0.18.8 has unspecified impact and rem
- CVE-2013-3527 HIGH 7.5 UPGRADE Multiple SQL injection vulnerabilities in Vanilla Forums before 2.0.18.8 allow remote attackers to execute arb
- CVE-2012-6555 MEDIUM 4.3 DOWNGRADE Cross-site scripting (XSS) vulnerability in the LatestComment plugin 1.1 for Vanilla Forums allows remote atta
- CVE-2012-4954 LOW 3.5 UPGRADE UPGRADE The edit-profile page in Vanilla Forums before 2.1a32 allows remote authenticated users to modify arbitrary pr
- CVE-2011-3614 CRITICAL 9.8 UPGRADE An Access Control vulnerability exists in the Facebook, Twitter, and Embedded plugins in Vanilla Forums before
- CVE-2011-3613 HIGH 7.5 UPGRADE An issue exists in Vanilla Forums before 2.0.17.9 due to the way cookies are handled.
- CVE-2011-1009 MEDIUM 6.1 UPGRADE Vanilla Forums 2.0.17.1 through 2.0.17.5 has XSS in /vanilla/index.php via the p parameter.
- CVE-2010-4266 MEDIUM 6.1 UPGRADE It was found in vanilla forums before 2.0.10 a potential linkbait vulnerability in dispatcher.
- CVE-2010-4264 MEDIUM 6.1 UPGRADE It was found in vanilla forums before 2.0.10 a cross-site scripting vulnerability where a filename could conta
FAQ
How do I fix vanillaforums vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is vanillaforums being exploited right now?
None of the tracked vanillaforums CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which vanillaforums CVE should I patch first?
CVE-2018-18903 currently ranks highest (67/100): Vanilla 2.6.x before 2.6.4 allows remote code execution..