yaws vulnerabilities
Recent CVEs affecting yaws products. 5 tracked.
yaws has 5 tracked vulnerabilities, 2 critical. A fixed release or vendor patch exists for 4. Most recent: 2020-09-09. Highest priority: CVE-2020-24916 (score 74/100).
- CVE-2020-24916 CRITICAL 9.8 UPGRADE MITIGATE CGI implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to OS command injection.
- CVE-2020-24379 CRITICAL 9.8 UPGRADE MITIGATE WebDAV implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to XXE injection.
- CVE-2020-12872 MEDIUM 5.5 UPGRADE yaws_config.erl in Yaws through 2.0.2 and/or 2.0.7 loads obsolete TLS ciphers, as demonstrated by ones that al
- CVE-2016-1000108 MEDIUM 6.1 UPGRADE MITIGATE yaws before 2.0.4 does not attempt to address RFC 3875 section 4.1.18 namespace conflicts and therefore does n
- CVE-2011-4350 MEDIUM 6.5 DOWNGRADE MITIGATE Yaws 1.91 has a directory traversal vulnerability in the way certain URLs are processed
FAQ
How do I fix yaws vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is yaws being exploited right now?
None of the tracked yaws CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which yaws CVE should I patch first?
CVE-2020-24916 currently ranks highest (74/100): CGI implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to OS command injection..