<?xml version="1.0" encoding="UTF-8"?><?xml-stylesheet type="text/xsl" href="../assets/feed.xsl"?><rss version="2.0"><channel><title>PatchTheCVE: zenml</title><link>https://patchthecve.com/</link><description>CVEs with upgrade or downgrade fix steps</description><item><title>CVE-2025-8406: ZenML version 0.83.1 is affected by a path traversal vulnerability in the `PathMaterializer` class</title><link>https://patchthecve.com/cve/CVE-2025-8406.html</link><guid>https://patchthecve.com/cve/CVE-2025-8406.html</guid><pubDate>Mon, 19 Oct 2026 16:10:00 +0000</pubDate><description>HIGH 7.8: ZenML version 0.83.1 is affected by a path traversal vulnerability in the `PathMaterializer` class. The `load` function uses `is_path_within_directory` to validate files during `data.tar.gz` extraction, which fails to effectively detect symbolic and hard links. This vulnerability can lead to arbitra</description></item><item><title>CVE-2024-9340: A Denial of Service (DoS) vulnerability in zenml-io/zenml version 0.66.0 allows unauthenticated attackers to c</title><link>https://patchthecve.com/cve/CVE-2024-9340.html</link><guid>https://patchthecve.com/cve/CVE-2024-9340.html</guid><pubDate>Wed, 17 Jun 2026 08:24:22 +0000</pubDate><description>HIGH 7.5: A Denial of Service (DoS) vulnerability in zenml-io/zenml version 0.66.0 allows unauthenticated attackers to cause excessive resource consumption by sending malformed multipart requests with arbitrary characters appended to the end of multipart boundaries. This flaw in the multipart request boundary</description></item><item><title>CVE-2024-4311: zenml-io/zenml version 0.56.4 is vulnerable to an account takeover due to the lack of rate-limiting in the pas</title><link>https://patchthecve.com/cve/CVE-2024-4311.html</link><guid>https://patchthecve.com/cve/CVE-2024-4311.html</guid><pubDate>Wed, 17 Jun 2026 08:01:38 +0000</pubDate><description>MEDIUM 5.4: zenml-io/zenml version 0.56.4 is vulnerable to an account takeover due to the lack of rate-limiting in the password change function. An attacker can brute-force the current password in the &#x27;Update Password&#x27; function, allowing them to take over the user&#x27;s account. This vulnerability is due to the abs</description></item><item><title>CVE-2024-5062: A reflected Cross-Site Scripting (XSS) vulnerability was identified in zenml-io/zenml version 0.57.1</title><link>https://patchthecve.com/cve/CVE-2024-5062.html</link><guid>https://patchthecve.com/cve/CVE-2024-5062.html</guid><pubDate>Wed, 17 Jun 2026 08:15:00 +0000</pubDate><description>MEDIUM 6.1: A reflected Cross-Site Scripting (XSS) vulnerability was identified in zenml-io/zenml version 0.57.1. The vulnerability exists due to improper neutralization of input during web page generation, specifically within the survey redirect parameter. This flaw allows an attacker to redirect users to a sp</description></item><item><title>CVE-2024-4680: A vulnerability in zenml-io/zenml version 0.56.3 allows attackers to reuse old session credentials or session </title><link>https://patchthecve.com/cve/CVE-2024-4680.html</link><guid>https://patchthecve.com/cve/CVE-2024-4680.html</guid><pubDate>Wed, 17 Jun 2026 08:02:24 +0000</pubDate><description>HIGH 8.8: A vulnerability in zenml-io/zenml version 0.56.3 allows attackers to reuse old session credentials or session IDs due to insufficient session expiration. Specifically, the session does not expire after a password change, enabling an attacker to maintain access to a compromised account without the vi</description></item><item><title>CVE-2024-2383: A clickjacking vulnerability exists in zenml-io/zenml versions up to and including 0.55.5 due to the applicati</title><link>https://patchthecve.com/cve/CVE-2024-2383.html</link><guid>https://patchthecve.com/cve/CVE-2024-2383.html</guid><pubDate>Wed, 17 Jun 2026 07:24:25 +0000</pubDate><description>MEDIUM 6.1: A clickjacking vulnerability exists in zenml-io/zenml versions up to and including 0.55.5 due to the application&#x27;s failure to set appropriate X-Frame-Options or Content-Security-Policy HTTP headers. This vulnerability allows an attacker to embed the application UI within an iframe on a malicious pag</description></item><item><title>CVE-2024-2213: An issue was discovered in zenml-io/zenml versions up to and including 0.55.4</title><link>https://patchthecve.com/cve/CVE-2024-2213.html</link><guid>https://patchthecve.com/cve/CVE-2024-2213.html</guid><pubDate>Wed, 17 Jun 2026 07:23:56 +0000</pubDate><description>LOW 3.3: An issue was discovered in zenml-io/zenml versions up to and including 0.55.4. Due to improper authentication mechanisms, an attacker with access to an active user session can change the account password without needing to know the current password. This vulnerability allows for unauthorized account</description></item><item><title>CVE-2024-2171: A stored Cross-Site Scripting (XSS) vulnerability was identified in the zenml-io/zenml repository, specificall</title><link>https://patchthecve.com/cve/CVE-2024-2171.html</link><guid>https://patchthecve.com/cve/CVE-2024-2171.html</guid><pubDate>Wed, 17 Jun 2026 07:23:51 +0000</pubDate><description>MEDIUM 4.8: A stored Cross-Site Scripting (XSS) vulnerability was identified in the zenml-io/zenml repository, specifically within the &#x27;logo_url&#x27; field. By injecting malicious payloads into this field, an attacker could send harmful messages to other users, potentially compromising their accounts. The vulnerabi</description></item><item><title>CVE-2024-2035: An improper authorization vulnerability exists in the zenml-io/zenml repository, specifically within the API P</title><link>https://patchthecve.com/cve/CVE-2024-2035.html</link><guid>https://patchthecve.com/cve/CVE-2024-2035.html</guid><pubDate>Wed, 17 Jun 2026 07:23:36 +0000</pubDate><description>MEDIUM 6.5: An improper authorization vulnerability exists in the zenml-io/zenml repository, specifically within the API PUT /api/v1/users/id endpoint. This vulnerability allows any authenticated user to modify the information of other users, including changing the `active` status of user accounts to false, eff</description></item><item><title>CVE-2024-2032: A race condition vulnerability exists in zenml-io/zenml versions up to and including 0.55.3, which allows for </title><link>https://patchthecve.com/cve/CVE-2024-2032.html</link><guid>https://patchthecve.com/cve/CVE-2024-2032.html</guid><pubDate>Wed, 17 Jun 2026 07:23:35 +0000</pubDate><description>LOW 3.1: A race condition vulnerability exists in zenml-io/zenml versions up to and including 0.55.3, which allows for the creation of multiple users with the same username when requests are sent in parallel. This issue was fixed in version 0.55.5. The vulnerability arises due to insufficient handling of con</description></item></channel></rss>