plug vulnerabilities and fixes
Recent CVEs affecting plug, with upgrade or downgrade steps. 3 tracked.
plug has 3 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 3. Most recent: 2018-12-20. Highest priority: CVE-2017-1000053 (score 53/100).
- CVE-2018-1000883 MEDIUM 6.5 UPGRADE Elixir Plug Plug version All contains a Header Injection vulnerability in Connection that can result in Given
- CVE-2017-1000053 HIGH 8.1 UPGRADE Elixir Plug before v1.0.4, v1.1.7, v1.2.3 and v1.3.2 is vulnerable to arbitrary code execution in the deserial
- CVE-2017-1000052 HIGH 7.8 UPGRADE Elixir Plug before v1.0.4, v1.1.7, v1.2.3 and v1.3.2 is vulnerable to null byte injection in the Plug.Static c
FAQ
How do I fix plug vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is plug being exploited right now?
None of the tracked plug CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which plug CVE should I patch first?
CVE-2017-1000053 currently ranks highest (53/100): Elixir Plug before v1.0.4, v1.1.7, v1.2.3 and v1.3.2 is vulnerable to arbitrary code execution in the deserial.