dronecode vulnerabilities
Recent CVEs affecting dronecode products. 12 tracked.
dronecode has 12 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 12. Most recent: 2026-03-19. Highest priority: CVE-2024-40427 (score 40/100).
- CVE-2025-15150 MEDIUM 5.3 UPGRADE A vulnerability was found in PX4 PX4-Autopilot up to 1.16.0
- CVE-2026-32743 MEDIUM 6.5 UPGRADE PX4 is an open-source autopilot stack for drones and unmanned vehicles
- CVE-2026-32724 MEDIUM 5.3 UPGRADE PX4 autopilot is a flight control solution for drones
- CVE-2026-32713 MEDIUM 4.3 UPGRADE PX4 autopilot is a flight control solution for drones
- CVE-2026-32709 MEDIUM 5.4 UPGRADE PX4 autopilot is a flight control solution for drones
- CVE-2026-32708 HIGH 7.8 UPGRADE PX4 autopilot is a flight control solution for drones
- CVE-2026-32707 MEDIUM 5.2 UPGRADE PX4 autopilot is a flight control solution for drones
- CVE-2026-32706 HIGH 7.1 UPGRADE PX4 autopilot is a flight control solution for drones
- CVE-2026-32705 MEDIUM 6.8 UPGRADE PX4 autopilot is a flight control solution for drones
- CVE-2026-26742 HIGH 8.1 UPGRADE PX4 Autopilot versions 1.12.x through 1.15.x contain a protection mechanism failure in the "Re-arm Grace Perio
- CVE-2026-26741 HIGH 8.1 UPGRADE PX4 Autopilot versions 1.12.x through 1.15.x contain a logic flaw in the mode switching mechanism
- CVE-2024-40427 HIGH 7.9 UPGRADE Stack Buffer Overflow in PX4-Autopilot v1.14.3, which allows attackers to execute commands to exploit this vul
FAQ
How do I fix dronecode vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is dronecode being exploited right now?
None of the tracked dronecode CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which dronecode CVE should I patch first?
CVE-2024-40427 currently ranks highest (40/100): Stack Buffer Overflow in PX4-Autopilot v1.14.3, which allows attackers to execute commands to exploit this vul.