grandstream vulnerabilities
Recent CVEs affecting grandstream products. 4 tracked.
grandstream has 4 tracked vulnerabilities, 1 critical. A fixed release or vendor patch exists for 4. Most recent: 2026-02-18. Highest priority: CVE-2026-2329 (score 72/100).
- CVE-2025-28171 MEDIUM 6.5 UPGRADE An issue in Grandstream UCM6510 v.1.0.20.52 and before allows a remote attacker to obtain sensitive informatio
- CVE-2025-28172 MEDIUM 6.5 UPGRADE Grandstream Networks UCM6510 v1.0.20.52 and before is vulnerable to Improper Restriction of Excessive Authenti
- CVE-2025-28170 HIGH 7.6 UPGRADE Grandstream Networks GXP1628 <=1.0.4.130 is vulnerable to Incorrect Access Control
- CVE-2026-2329 CRITICAL 9.8 UPGRADE UPGRADE An unauthenticated stack-based buffer overflow vulnerability exists in the HTTP API endpoint /cgi-bin/api.valu
FAQ
How do I fix grandstream vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is grandstream being exploited right now?
None of the tracked grandstream CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which grandstream CVE should I patch first?
CVE-2026-2329 currently ranks highest (72/100): An unauthenticated stack-based buffer overflow vulnerability exists in the HTTP API endpoint /cgi-bin/api.valu.