modbustools vulnerabilities
Recent CVEs affecting modbustools products. 3 tracked.
modbustools has 3 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 3. Most recent: 2022-12-30. Highest priority: CVE-2022-4857 (score 40/100).
- CVE-2022-4857 MEDIUM 6.3 UPGRADE A vulnerability was found in Modbus Tools Modbus Poll up to 9.10.0 and classified as critical
- CVE-2022-4856 MEDIUM 6.3 UPGRADE A vulnerability has been found in Modbus Tools Modbus Slave up to 7.5.1 and classified as critical
- CVE-2022-1068 MEDIUM 5.5 UPGRADE Modbus Tools Modbus Slave (versions 7.4.2 and prior) is vulnerable to a stack-based buffer overflow in the reg
FAQ
How do I fix modbustools vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is modbustools being exploited right now?
None of the tracked modbustools CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which modbustools CVE should I patch first?
CVE-2022-4857 currently ranks highest (40/100): A vulnerability was found in Modbus Tools Modbus Poll up to 9.10.0 and classified as critical.