nic vulnerabilities
Recent CVEs affecting nic products. 16 tracked.
nic has 16 tracked vulnerabilities, 1 critical. A fixed release or vendor patch exists for 16. Most recent: 2023-10-22. Highest priority: CVE-2019-19331 (score 62/100).
- CVE-2023-46317 HIGH 7.5 UPGRADE Knot Resolver before 5.7.0 performs many TCP reconnections upon receiving certain nonsensical responses from s
- CVE-2023-26249 HIGH 7.5 UPGRADE Knot Resolver before 5.6.0 enables attackers to consume its resources, launching amplification attacks and pot
- CVE-2022-40188 HIGH 7.5 UPGRADE MITIGATE Knot Resolver before 5.5.3 allows remote attackers to cause a denial of service (CPU consumption) because of a
- CVE-2022-32983 MEDIUM 5.3 UPGRADE Knot Resolver through 5.5.1 may allow DNS cache poisoning when there is an attempt to limit forwarding actions
- CVE-2021-40083 HIGH 7.5 UPGRADE Knot Resolver before 5.3.2 is prone to an assertion failure, triggerable by a remote attacker in an edge case
- CVE-2021-3346 CRITICAL 9.8 UPGRADE Foris before 101.1.1, as used in Turris OS, lacks certain HTML escaping in the login template.
- CVE-2021-26928 MEDIUM 6.8 UPGRADE BIRD through 2.0.7 does not provide functionality for password authentication of BGP peers
- CVE-2020-12667 HIGH 7.5 UPGRADE Knot Resolver before 5.1.1 allows traffic amplification via a crafted DNS answer from an attacker-controlled s
- CVE-2019-19331 HIGH 7.5 UPGRADE MITIGATE knot-resolver before version 4.3.0 is vulnerable to denial of service through high CPU utilization
- CVE-2019-10191 HIGH 7.5 UPGRADE MITIGATE A vulnerability was discovered in DNS resolver of knot resolver before version 4.1.0 which allows remote attac
- CVE-2019-10190 HIGH 7.5 UPGRADE MITIGATE A vulnerability was discovered in DNS resolver component of knot resolver through version 3.2.0 before 4.1.0 w
- CVE-2018-1110 HIGH 7.5 UPGRADE A flaw was found in knot-resolver before version 2.3.0
- CVE-2018-10920 MEDIUM 6.8 UPGRADE Improper input validation bug in DNS resolver component of Knot Resolver before 2.4.1 allows remote attacker t
- CVE-2018-1000002 LOW 3.7 UPGRADE Improper input validation bugs in DNSSEC validators components in Knot Resolver (prior version 1.5.2) allow at
- CVE-2014-0486 HIGH 7.5 UPGRADE Knot DNS before 1.5.2 allows remote attackers to cause a denial of service (application crash) via a crafted D
- CVE-2013-5661 MEDIUM 5.9 UPGRADE DOWNGRADE Cache Poisoning issue exists in DNS Response Rate Limiting.
FAQ
How do I fix nic vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is nic being exploited right now?
None of the tracked nic CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which nic CVE should I patch first?
CVE-2019-19331 currently ranks highest (62/100): knot-resolver before version 4.3.0 is vulnerable to denial of service through high CPU utilization.