terser vulnerabilities
Recent CVEs affecting terser products. 2 tracked.
terser has 2 tracked vulnerabilities, 0 critical. A fixed release or vendor patch exists for 2. Most recent: 2022-10-31. Highest priority: CVE-2022-25858 (score 51/100).
- CVE-2022-37620 HIGH 7.5 UPGRADE UPGRADE A Regular Expression Denial of Service (ReDoS) flaw was found in kangax html-minifier 4.0.0 because of the reC
- CVE-2022-25858 MEDIUM 5.3 UPGRADE The package terser before 4.8.1, from 5.0.0 and before 5.14.2 are vulnerable to Regular Expression Denial of S
FAQ
How do I fix terser vulnerabilities?
Open the CVE for your version, check the affected range, then follow the listed action: upgrade to the fixed release, or downgrade or mitigate if no fix exists yet. Commands for each OS are shown on every CVE page.
Is terser being exploited right now?
None of the tracked terser CVEs are on the CISA Known Exploited Vulnerabilities list at the moment. This is checked every 20 minutes.
Which terser CVE should I patch first?
CVE-2022-25858 currently ranks highest (51/100): The package terser before 4.8.1, from 5.0.0 and before 5.14.2 are vulnerable to Regular Expression Denial of S.